User:Mina

(Difference between revisions)
Jump to: navigation, search
(Some notes to self)
m
Line 13: Line 13:
 
This error could certainly be corrected by modifying pkgApp.pl script in the util folder, but I'm unable to do it myself.
 
This error could certainly be corrected by modifying pkgApp.pl script in the util folder, but I'm unable to do it myself.
  
'''Update (26.08.2012)''': thanks to fixes by T. Reaves, this problem is now history. Thanks Timothy :-)
+
'''Update (26.08.2012)''': thanks to fixes by T. Reaves, this problem is now history (as of revision 5556). Thanks Timothy :-)

Revision as of 19:25, 26 August 2012

User of Stellarium on Mac OS X and of a Digitarium Alpha planetarium projector.

Interested in the compilation of Stellarium on Mac OS X.

Some notes to self

Everything seems OK under OS X 10.8.1, but getting "Incompatible library version: libintl.8.dylib requires version 8.0.0 or later, but libiconv.2.dylib provides version 7.0.0" error at launch, even after reinstalling completely MacPorts.

Cause: during package building, the OS libiconv.2.dylib file (v7.00) is used instead of MacPorts version.

Manual fix: copy /opt/local/lib/libiconv.2.dylib into the Stellarium.app package, replacing OS X version of it.

This error could certainly be corrected by modifying pkgApp.pl script in the util folder, but I'm unable to do it myself.

Update (26.08.2012): thanks to fixes by T. Reaves, this problem is now history (as of revision 5556). Thanks Timothy :-)

Personal tools
Namespaces
Variants
Actions
in this wiki
other languages
Toolbox