Talk:Compilation on Linux

(Difference between revisions)
Jump to: navigation, search
(mkinstalldirs)
Line 19: Line 19:
 
but on "make" I still run into the same error.
 
but on "make" I still run into the same error.
 
Fabien has added a macro to seek the boost library on configure, but the error remains.
 
Fabien has added a macro to seek the boost library on configure, but the error remains.
 +
 +
== mkinstalldirs ==
 +
 +
A file of "mkinstalldirs" is included in 0.8.2 tar ball. I think that it only have to be copied for svn version. And in Ubnutu 6.10, directory which exist "mkinstalldirs" is <code>/usr/share/automake-1.9/</code>.--[[User:Sigma|Sigma]] 02:46, 7 February 2007 (PST)

Revision as of 10:46, 7 February 2007

Contents

Compiling on Ubuntu

With a normal install of Ubuntu 5.10, I also needed to install automake and the freetype library to compile Stellarium.


Note from Barry Gerdes on the apt-get command

This worked correctly for me the first time I tried it but when I tried it on my second computer with a different ISP it hung because it could not find "libfreetype6-dev cvs" I re-entered the above command without this and got all the rest OK then did a search and downloaded the file separately from www.freetype.org

Response: The apt-get failure could have been a network glitch, or that the two machines had different repository settings (either download from different mirrors, one of which was missing some files, or that one machine didn't have multiverse enabled or something) Matthewg42 03:53, 18 April 2006 (PDT)

Subversion development version 1545 Boost error?

I'm running into problems with the latest SVN code (1545). When doing "make", I get this error. It's something to do with the Boost library, but I can't resolve it.

stelmodule.h: In member function ‘ValueType StelModule::getProperty(const std::string&)’:
stelmodule.h:106: error: no matching function for call to ‘StelModule::propertyAccessor::get() const’

I've done

./configure --with-boost=./configure --with-boost=/usr/local/include/boost/

but on "make" I still run into the same error. Fabien has added a macro to seek the boost library on configure, but the error remains.

mkinstalldirs

A file of "mkinstalldirs" is included in 0.8.2 tar ball. I think that it only have to be copied for svn version. And in Ubnutu 6.10, directory which exist "mkinstalldirs" is /usr/share/automake-1.9/.--Sigma 02:46, 7 February 2007 (PST)

Personal tools
Namespaces
Variants
Actions
in this wiki
other languages
Toolbox