Build Dependencies

(Difference between revisions)
Jump to: navigation, search
Line 3: Line 3:
 
{| cellpadding=2 border=1 width=80%
 
{| cellpadding=2 border=1 width=80%
 
| '''Dependency''' || '''Ubuntu package name''' || '''Notes'''   
 
| '''Dependency''' || '''Ubuntu package name''' || '''Notes'''   
|-
 
||[http://www.gnu.org/software/automake/ Automake] || automake1.9 || Not required >= Stellarium v0.9.0. We now use CMake.
 
|-
 
||[http://www.gnu.org/software/autoconf/ Autoconf] || autoconf || Not required >= Stellarium v0.9.0. We now use CMake.
 
 
|-
 
|-
 
||[http://www.cmake.org/ CMake] || cmake || Required >= Stellarium 0.9.0.  Get version 2.4-patch 7 or higher of CMake.
 
||[http://www.cmake.org/ CMake] || cmake || Required >= Stellarium 0.9.0.  Get version 2.4-patch 7 or higher of CMake.
Line 19: Line 15:
 
|-
 
|-
 
||GLU || libglu1-mesa-dev ||
 
||GLU || libglu1-mesa-dev ||
|-
 
||[http://www.libsdl.org SDL] || libsdl-dev ||
 
 
|-
 
|-
 
||[http://www.zlib.net Zlib] || zlib1g-dev ||
 
||[http://www.zlib.net Zlib] || zlib1g-dev ||
Line 32: Line 26:
 
||JPEG libraries || libjpeg62-dev || New in version 0.9.x
 
||JPEG libraries || libjpeg62-dev || New in version 0.9.x
 
|-
 
|-
||Curl library || libcurl3-dev || Only for version 0.9.0. ''Not needed for version 0.9.1.''
+
||QT library >= 4.4.1 || libqt4-dev* || You must make sure that if you have alternatives for QT development tools for QT3, that you set up your alternatives to point at the QT4 versions of the tools (moc etc.).
|-
+
'''Note: If you want to build recent SVN, you will need version 4.4 of QT'''.  Sadly this it not yet in the stable Ubuntu repositories, so you will have to build it from source, or get hold of the 4.4 package from the backports repositry.
||QT 4.3 library || libqt4-dev || New in version 0.9.x.  You must make sure that if you have alternatives for QT development tools for QT3, that you set up your alternatives to point at the QT4 versions of the tools (moc etc.). Since SVN revision 2162, QT is required, not just an optional dependency. 
+
'''Note: If you want to build recent SVN, you will need version 4.4 of QT'''.  Sadly this it not yet in the Ubuntu repositories, so you will have to build it from source, or get hold of the 4.4 package from the backports repositry.
+
 
|-
 
|-
 
||Doxygen || doxygen || ''Optional''. If you want to build the API documentation you will need this.
 
||Doxygen || doxygen || ''Optional''. If you want to build the API documentation you will need this.
 
|-
 
|-
 
||Graphviz || graphviz || ''Optional''. If you want to build the API document and include fancy class diagrams, you will need this.
 
||Graphviz || graphviz || ''Optional''. If you want to build the API document and include fancy class diagrams, you will need this.
|-
 
||SDL-mixer || libsdl-mixer1.2-dev || ''Optional''. If you want to enable audio features in scripting.
 
 
|-
 
|-
 
||Subversion || subversion || ''Optional''. Only necessary if you want to build the latest development version (not the "release" versions).
 
||Subversion || subversion || ''Optional''. Only necessary if you want to build the latest development version (not the "release" versions).
 
|-
 
|-
 
|}
 
|}
 
This list is getting quite long…  We hope to remove some dependencies after the 0.9.0 release.
 
  
 
'''Linux users''': If your distribution separates libraries into normal and development version, ''make sure you get the development ones'' (e.g. in Debian/Ubuntu, the '''-dev''' packages).
 
'''Linux users''': If your distribution separates libraries into normal and development version, ''make sure you get the development ones'' (e.g. in Debian/Ubuntu, the '''-dev''' packages).
Ubuntu users can install all these dependencies in one go by running this command in a terminal:
+
Ubuntu users can install all these dependencies in one go by running this command in a terminal (so long as they have the right repositories enabled):
  sudo aptitude install build-essential libfreetype6-dev cvs libsdl-mixer1.2-dev \
+
  sudo aptitude install build-essential libfreetype6-dev cmake \
       libpng12-dev libsdl1.2-dev zlib1g-dev libglu1-mesa-dev libgl1-mesa-dev gcc \
+
       libpng12-dev zlib1g-dev libglu1-mesa-dev libgl1-mesa-dev gcc \
 
       g++ gettext libboost-dev libboost-thread-dev libjpeg-dev \
 
       g++ gettext libboost-dev libboost-thread-dev libjpeg-dev \
       libboost-filesystem-dev subversion libqt4-dev graphviz doxygen cmake
+
       libboost-filesystem-dev subversion libqt4-dev graphviz doxygen
 
+
Ubuntu Dapper users (long term support release) will have to download and build CMake first—the version of CMake from the Dapper repositories is too old.
+
  
 
For Mandriva users the command line is:
 
For Mandriva users the command line is:

Revision as of 09:35, 20 October 2008

Stellarium needs a few things to be installed on your system before you can build it.

Dependency Ubuntu package name Notes
CMake cmake Required >= Stellarium 0.9.0. Get version 2.4-patch 7 or higher of CMake.
GNU C Compiler gcc Or compatible alternative.
GNU C++ Compiler g++ Or compatible alternative.
gettext gettext
Open GL libgl1-mesa-dev
GLU libglu1-mesa-dev
Zlib zlib1g-dev
PNG libpng12-dev
Freetype libfreetype6-dev Apparently at least later than 2.1.0.
Boost C++ Libraries libboost-dev Since about 2006-08-28.
JPEG libraries libjpeg62-dev New in version 0.9.x
QT library >= 4.4.1 libqt4-dev* You must make sure that if you have alternatives for QT development tools for QT3, that you set up your alternatives to point at the QT4 versions of the tools (moc etc.).

Note: If you want to build recent SVN, you will need version 4.4 of QT. Sadly this it not yet in the stable Ubuntu repositories, so you will have to build it from source, or get hold of the 4.4 package from the backports repositry.

Doxygen doxygen Optional. If you want to build the API documentation you will need this.
Graphviz graphviz Optional. If you want to build the API document and include fancy class diagrams, you will need this.
Subversion subversion Optional. Only necessary if you want to build the latest development version (not the "release" versions).

Linux users: If your distribution separates libraries into normal and development version, make sure you get the development ones (e.g. in Debian/Ubuntu, the -dev packages). Ubuntu users can install all these dependencies in one go by running this command in a terminal (so long as they have the right repositories enabled):

sudo aptitude install build-essential libfreetype6-dev cmake \
     libpng12-dev zlib1g-dev libglu1-mesa-dev libgl1-mesa-dev gcc \
     g++ gettext libboost-dev libboost-thread-dev libjpeg-dev \
     libboost-filesystem-dev subversion libqt4-dev graphviz doxygen

For Mandriva users the command line is:

urpmi libmesagl1-devel libmesaglu1-devel libSDL1.2-devel libSDL_sound1.0-devel zlib1-devel \
     libpng-devel libfreetype6-devel libboost1-devel libjpeg62-devel libqt4-devel doxygen \
     graphviz libSDL_mixer1.2-devel cmake
Personal tools
Namespaces
Variants
Actions
in this wiki
other languages
Toolbox