CMakeLists.txt   CMakeLists.txt 
skipping to change at line 27 skipping to change at line 27
ENDIF() ENDIF()
# warn about deprecated stuff so that we may try fixing it # warn about deprecated stuff so that we may try fixing it
SET(CMAKE_WARN_DEPRECATED 1) SET(CMAKE_WARN_DEPRECATED 1)
########### Project name ########### ########### Project name ###########
PROJECT(Stellarium) PROJECT(Stellarium)
# Use integer versions instead of strings for easier handling if required # Use integer versions instead of strings for easier handling if required
SET(STELLARIUM_MAJOR 0) SET(STELLARIUM_MAJOR 0)
SET(STELLARIUM_MINOR 16) SET(STELLARIUM_MINOR 16)
SET(STELLARIUM_PATCH 0) SET(STELLARIUM_PATCH 1)
ADD_DEFINITIONS( ADD_DEFINITIONS(
-DSTELLARIUM_MAJOR=${STELLARIUM_MAJOR} -DSTELLARIUM_MAJOR=${STELLARIUM_MAJOR}
-DSTELLARIUM_MINOR=${STELLARIUM_MINOR} -DSTELLARIUM_MINOR=${STELLARIUM_MINOR}
-DSTELLARIUM_PATCH=${STELLARIUM_PATCH} -DSTELLARIUM_PATCH=${STELLARIUM_PATCH}
) )
SET(VERSION "${STELLARIUM_MAJOR}.${STELLARIUM_MINOR}.${STELLARIUM_PATCH}") SET(VERSION "${STELLARIUM_MAJOR}.${STELLARIUM_MINOR}.${STELLARIUM_PATCH}")
SET(PACKAGE stellarium) SET(PACKAGE stellarium)
SET(COPYRIGHT_YEARS "2000-2017") SET(COPYRIGHT_YEARS "2000-2017")
SET(PACKAGE_VERSION "${VERSION}") SET(PACKAGE_VERSION "${VERSION}")
ADD_DEFINITIONS(-DPACKAGE_VERSION="${PACKAGE_VERSION}") ADD_DEFINITIONS(-DPACKAGE_VERSION="${PACKAGE_VERSION}")
ADD_DEFINITIONS(-DCOPYRIGHT_YEARS="${COPYRIGHT_YEARS}") ADD_DEFINITIONS(-DCOPYRIGHT_YEARS="${COPYRIGHT_YEARS}")
# Write version of Stellarium to Stellarium User Guide # Write version of Stellarium to Stellarium User Guide
CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/cmake/version.tex.cmake ${PROJECT_SOUR CE_DIR}/guide/version.tex @ONLY NEWLINE_STYLE LF) CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/cmake/version.tex.cmake ${PROJECT_SOUR CE_DIR}/guide/version.tex @ONLY NEWLINE_STYLE LF)
CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/cmake/README.cmake ${PROJECT_SOURCE_DI R}/README @ONLY)
# currently Qt 5.4 - 5.6 is recommended, we can no longer build with Qt 5.3 , and 5.7 may have some bugs (on Mac? 5.7 is fine on Windows) 5.8 on Window s seems OK. # currently Qt 5.4 - 5.6 is recommended, we can no longer build with Qt 5.3 , and 5.7 may have some bugs (on Mac? 5.7 is fine on Windows) 5.8 on Window s seems OK.
SET(MINIMAL_QT_VERSION "5.4.0") SET(MINIMAL_QT_VERSION "5.4.0")
# Use customized cmake macros # Use customized cmake macros
SET(CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake/modules) SET(CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake/modules)
# Show platform info # Show platform info
MESSAGE(STATUS "Platform: ${CMAKE_SYSTEM}") MESSAGE(STATUS "Platform: ${CMAKE_SYSTEM}")
 End of changes. 2 change blocks. 
1 lines changed or deleted 2 lines changed or added

This html diff was produced by rfcdiff 1.41. The latest version is available from http://tools.ietf.org/tools/rfcdiff/